[vc_row full_width=”” parallax=”” parallax_image=”” background_style=”pivot-normal” single_link=””][vc_column width=”1/1″][vc_progress_bar values=”90|Hartneckigkeit,80|Dummheit,70|Wahnsinnig werden Faktor” bgcolor=”bar_green” options=”animated” units=”…..Pro Mille in Blut”][vc_column_text css_animation=””]WARNUNG: Die folgenden Pakete können nicht authentifiziert werden!

mod-pagespeed-stable

https://developers.google.com/speed/pagespeed/module/release_notes

Probleme beim Installieren des Moduls.

WARNING: The following packages cannot be authenticated!

http://dl.google.com/linux/mod-pagespeed/deb/pool/main/m/mod-pagespeed-stable/mod-pagespeed-stable_1.9.32.4-r7251_amd64.deb

Ich könnte mal wieder zusammenbrechen!!! Wie unglaublich ist das denn, versucht da nicht wirklich jemand ein mega sicheres Modul über http also Port 80 in unseren Server zu schieben, also dieser Dummheit gehört der Kopf abgeschlagen. Doch wer ist dafür verantwortlich. 3-mal darfst du raten. Ich sag nix, am Ende bekomme ich die Seiten nicht mehr in den Google Index. Egal. Schauen wir uns mal an wie wir das Problem lösen können.

Am einfachsten einfach mal den Link oben auf https trimmen und mit wget reinziehen und drüber installieren.

https://dl.google.com/linux/mod-pagespeed/deb/pool/main/m/mod-pagespeed-stable/mod-pagespeed-stable_1.9.32.4-r7251_amd64.deb

ok, geht so auch nicht. Wir ziehen uns erst mal den Key in das System:

wget http://modpagespeed.com/release_archive/1.9.32.4/mod-pagespeed-stable_1.9.32.4-r7251_amd64.deb.asc
apt-key add mod-pagespeed-stable_1.9.32.4-r7251_amd64.deb.asc

gpg: Keine gültigen OpenPGP-Daten gefunden.

Download geht aber Installation immer noch nicht. Schauen wir mal weiter.

Installieren wir es dann eben manuell. Fertig, Webserver Neustart und läuft. So sollte es sein, es kommt aber immer noch der Fehler oben.

Also weiter mit:

hier mal die vi-version: Falls der Download nicht geht vom Server aus, dann die Datei manuell anlegen.
* linux_signing_key.pub *
Quelle: https://www.google.com/linuxrepositories/

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

mQGiBEXwb0YRBADQva2NLpYXxgjNkbuP0LnPoEXruGmvi3XMIxjEUFuGNCP4Rj/a
kv2E5VixBP1vcQFDRJ+p1puh8NU0XERlhpyZrVMzzS/RdWdyXf7E5S8oqNXsoD1z
fvmI+i9b2EhHAA19Kgw7ifV8vMa4tkwslEmcTiwiw8lyUl28Wh4Et8SxzwCggDcA
feGqtn3PP5YAdD0km4S4XeMEAJjlrqPoPv2Gf//tfznY2UyS9PUqFCPLHgFLe80u
QhI2U5jt6jUKN4fHauvR6z3seSAsh1YyzyZCKxJFEKXCCqnrFSoh4WSJsbFNc4PN
b0V0SqiTCkWADZyLT5wll8sWuQ5ylTf3z1ENoHf+G3um3/wk/+xmEHvj9HCTBEXP
78X0A/0Tqlhc2RBnEf+AqxWvM8sk8LzJI/XGjwBvKfXe+l3rnSR2kEAvGzj5Sg0X
4XmfTg4Jl8BNjWyvm2Wmjfet41LPmYJKsux3g0b8yzQxeOA4pQKKAU3Z4+rgzGmf
HdwCG5MNT2A5XxD/eDd+L4fRx0HbFkIQoAi1J3YWQSiTk15fw7RMR29vZ2xlLCBJ
bmMuIExpbnV4IFBhY2thZ2UgU2lnbmluZyBLZXkgPGxpbnV4LXBhY2thZ2VzLWtl
eW1hc3RlckBnb29nbGUuY29tPohjBBMRAgAjAhsDBgsJCAcDAgQVAggDBBYCAwEC
HgECF4AFAkYVdn8CGQEACgkQoECDD3+sWZHKSgCfdq3HtNYJLv+XZleb6HN4zOcF
AJEAniSFbuv8V5FSHxeRimHx25671az+uQINBEXwb0sQCACuA8HT2nr+FM5y/kzI
A51ZcC46KFtIDgjQJ31Q3OrkYP8LbxOpKMRIzvOZrsjOlFmDVqitiVc7qj3lYp6U
rgNVaFv6Qu4bo2/ctjNHDDBdv6nufmusJUWq/9TwieepM/cwnXd+HMxu1XBKRVk9
XyAZ9SvfcW4EtxVgysI+XlptKFa5JCqFM3qJllVohMmr7lMwO8+sxTWTXqxsptJo
pZeKz+UBEEqPyw7CUIVYGC9ENEtIMFvAvPqnhj1GS96REMpry+5s9WKuLEaclWpd
K3krttbDlY1NaeQUCRvBYZ8iAG9YSLHUHMTuI2oea07Rh4dtIAqPwAX8xn36JAYG
2vgLAAMFB/wKqaycjWAZwIe98Yt0qHsdkpmIbarD9fGiA6kfkK/UxjL/k7tmS4Vm
CljrrDZkPSQ/19mpdRcGXtb0NI9+nyM5trweTvtPw+HPkDiJlTaiCcx+izg79Fj9
KcofuNb3lPdXZb9tzf5oDnmm/B+4vkeTuEZJ//IFty8cmvCpzvY+DAz1Vo9rA+Zn
cpWY1n6z6oSS9AsyT/IFlWWBZZ17SpMHu+h4Bxy62+AbPHKGSujEGQhWq8ZRoJAT
G0KSObnmZ7FwFWu1e9XFoUCt0bSjiJWTIyaObMrWu/LvJ3e9I87HseSJStfw6fki
5og9qFEkMrIrBCp3QGuQWBq/rTdMuwNFiEkEGBECAAkFAkXwb0sCGwwACgkQoECD
D3+sWZF/WACfeNAu1/1hwZtUo1bR+MWiCjpvHtwAnA1R3IHqFLQ2X3xJ40XPuAyY
/FJG
=Quqp
-----END PGP PUBLIC KEY BLOCK-----

sudo apt-key add linux_signing_key.pub

Geht immer noch nicht also über:

apt-get -y –force-yes install mod-pagespeed-stable

also dann so:

wget http://modpagespeed.com/release_archive/1.9.32.4/mod-pagespeed-stable_1.9.32.4-r7251_amd64.deb
sudo dpkg -i mod-pagespeed-stable_1.9.32.4-r7251_amd64.deb

dpkg: Fehler: dpkg-Status-Datenbank ist von einem anderen Prozess gesperrt

 

Welche Änderungen gibt es? Ganz einfach. Google hat die Schnauze voll, ständig in allen Google Programmen die Patches von OpenSSL einzupflegen, nun hat Google dafür das BoringSSL Projekt veröffentlicht. Hiermit soll Zeit, Geld und Nerven gespart werden. https://boringssl.googlesource.com/boringssl/

 [/vc_column_text][/vc_column][/vc_row]